Subject: [Yang-multicast] Meeting at the IETF before pim WG

From: Stig Venaas <[email-masked]>
Date: Tue, 21 Jul 2015 04:39:16 -0700

Hi

It would be good for us to meet before the pim WG session to review
the slides and also discuss the open issues we have in person. At the
lunch on Monday it seemed Thursday morning during the plenary was a
good option. Does that work for you? If not, can you suggest other
times that you would prefer?

Stig

---

From: Pete McAllister <[email-masked]>
Date: Tue, 21 Jul 2015 12:02:05 +0000

-----Original Message-----
From: Pete McAllister 
Sent: 21 July 2015 13:02
To: 'Stig Venaas'
Subject: RE: [Yang-multicast] Meeting at the IETF before pim WG

Works for me.

-----Original Message-----
From: Yang-multicast [mailto:[email-masked]] On Behalf Of Stig Venaas
Sent: 21 July 2015 12:39
To: [email-masked]
Subject: [Yang-multicast] Meeting at the IETF before pim WG

Hi

It would be good for us to meet before the pim WG session to review the slides and also discuss the open issues we have in person. At the lunch on Monday it seemed Thursday morning during the plenary was a good option. Does that work for you? If not, can you suggest other times that you would prefer?

Stig

_______________________________________________
Yang-multicast mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/yang-multicast

---

From: "Mahesh Sivakumar (masivaku)" <[email-masked]>
Date: Tue, 21 Jul 2015 16:38:15 +0000

Thursday morning works for me as well.

Thx
Mahesh

---

From: Stig Venaas <[email-masked]>
Date: Tue, 21 Jul 2015 15:10:56 -0700

Great. Let's aim for Thursday morning then. 9 at the registration desk?
Then we'll look for a room. Or I might ask around for rooms tomorrow.

Stig

Stig

---

From: Anish Peter <[email-masked]>
Date: Wed, 22 Jul 2015 08:52:02 +0200

Fine for me. Could you please let me know the duration, as we are 
planning to have a meet after that.

Thanks,
Anish

On 7/22/15 12:10 AM, Stig Venaas wrote:
>
> Great. Let's aim for Thursday morning then. 9 at the registration 
> desk? Then we'll look for a room. Or I might ask around for rooms 
> tomorrow.
>
> Stig
>
> Stig
>
>
>

---

From: Stig Venaas <[email-masked]>
Date: Wed, 22 Jul 2015 00:11:38 -0700

Hi

I was thinking it could be good to use the entire session, I'm not sure
what others think. Maybe 1-2 hours is enough?

I will try to check about reserving a room today.

Stig

---

From: Stig Venaas <[email-masked]>
Date: Wed, 22 Jul 2015 08:37:13 -0700

Hi

I think I managed to get us a room for tomorrow, but I don't know which one
yet. If I find out I will send an update. If not, let's meet at the
registration desk at 9.

Stig

---

From: Stig Venaas <[email-masked]>
Date: Wed, 22 Jul 2015 09:06:38 -0700

Hi, we are meeting in Florenc at 9, so please just come directly to
the meeting room,

Stig

---

From: Xufeng Liu <[email-masked]>
Date: Wed, 22 Jul 2015 22:11:33 +0000

Thanks, Stig.

Will meet you there.

- Xufeng

> Sent: Wednesday, July 22, 2015 12:07 PM
> Cc: [email-masked]
> Subject: Re: [Yang-multicast] Meeting at the IETF before pim WG
> 
> Hi, we are meeting in Florenc at 9, so please just come directly to the meeting
> room,
> 
> Stig
> 
> 
> > I think I managed to get us a room for tomorrow, but I don't know
> > which one yet. If I find out I will send an update. If not, let's meet
> > at the registration desk at 9.
> >
> > Stig
>

---

From: Stig Venaas <[email-masked]>
Date: Wed, 22 Jul 2015 23:57:32 -0700

I'm sorry but I will be a little late. I will come to Florenc about 9:15

Stig
 On Jul 23, 2015 12:11 AM, "Xufeng Liu" <[email-masked]> wrote:

> > From: Yang-multicast [mailto:[email-masked]] On Behalf
> Of
> > Stig Venaas

---

From: Pete McAllister <[email-masked]>
Date: Thu, 23 Jul 2015 13:57:29 +0000

Highlights from this morning’s discussion:

1.       We agreed that moving the interface list up a level so that AF is a sub-list of the interface list would be a good compromise. If, in addition, the AF-specific interface parameters are marked as features, everyone can both support the base model and easily augment it for their needs.

2.       We did not quite get as far as agreeing — though it seems logical — that entity-scoped config should use the same approach.

3.       The mode-specific RP config will be moved from the rp module to the individual mode modules as augmentations, resolving the SM & BI-DIR RP issue.

4.       We will consult other WGs and model designers to help resolve:

a.       How policy/ACL should be represented in a implementation-agnostic, clean way (presumably a typedef that implementors will augment with structure).

b.      Where BFD config lives.

c.       If there’s a generally-accepted model for resolving configuration that exists at different scopes for different implementations.

I’m happy to make updates to the draft based on 1–3 above (Xufeng, if you would rather update the model and I update the text, that’s fine too: let me know).  Anyone want to volunteer to own one or more of the discussions in 4?

From: Yang-multicast [mailto:[email-masked]] On Behalf Of Stig Venaas
Sent: 23 July 2015 07:58
To: Xufeng Liu <[email-masked]>
Cc: [email-masked]
Subject: Re: [Yang-multicast] Meeting at the IETF before pim WG

Stig
On Jul 23, 2015 12:11 AM, "Xufeng Liu" <[email-masked]<mailto:[email-masked]>> wrote:
Thanks, Stig.

Will meet you there.

- Xufeng

> From: Yang-multicast [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of
> Stig Venaas
> Cc: [email-masked]<mailto:[email-masked]>
> On Wed, Jul 22, 2015 at 8:37 AM, Stig Venaas <[email-masked]<mailto:[email-masked]>> wrote:
> > Hi
> >
> [email-masked]<mailto:[email-masked]>

---

From: Xufeng Liu <[email-masked]>
Date: Thu, 23 Jul 2015 20:58:50 +0000

Hi Pete,

Thanks for putting these together. I’ll make the changes and let you verify and correct.

Regards,

- Xufeng

From: Yang-multicast [mailto:[email-masked]] On Behalf Of Pete McAllister
Sent: Thursday, July 23, 2015 9:57 AM
To: [email-masked]
Subject: Re: [Yang-multicast] Meeting at the IETF before pim WG

From: Yang-multicast [mailto:[email-masked]] On Behalf Of Stig Venaas
Sent: 23 July 2015 07:58
To: Xufeng Liu <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Yang-multicast] Meeting at the IETF before pim WG

Stig

Will meet you there.

- Xufeng

---

From: Xufeng Liu <[email-masked]>
Date: Mon, 27 Jul 2015 19:54:05 +0000

Hi Pete,

I have updated the model files and tree views, and pushed them into the Github. Please check if the updates are correct.

Thanks,

- Xufeng

Stig

Will meet you there.

- Xufeng

---

From: Pete McAllister <[email-masked]>
Date: Tue, 28 Jul 2015 09:17:44 +0000

Great, thanks. I’ll be updating the text in the next day or two, so I’ll look over your changes then.

Pete

From: Xufeng Liu [mailto:[email-masked]]
Sent: 27 July 2015 20:54
To: Pete McAllister <[email-masked]>; [email-masked]
Subject: RE: [Yang-multicast] Meeting at the IETF before pim WG

Hi Pete,

Thanks,

- Xufeng

From: Yang-multicast [mailto:[email-masked]] On Behalf Of Pete McAllister
Sent: Thursday, July 23, 2015 9:57 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Yang-multicast] Meeting at the IETF before pim WG

Stig

Will meet you there.

- Xufeng