Subject: Re: [Yang-multicast] draft-ietf-pim-yang-01.txt ready for WGLC?

From: "Xufeng Liu" <[email-masked]>
Date: Mon, 1 Aug 2016 16:25:17 -0400

Hi Stig,

I think that it is an interesting topic to be discussed.

I have checked some other model drafts. Both durations and time stamps are
used. In general, time duration is used more than time stamps, as following:

Models that use during:
evpn: uint32
bfd: uint32
bgp: uint16, decimal64, yang:timeticks
ietf-routing: uint16, uint32
isis: uint16
l2vpn: uint32, uint16
ldp: uint16
key-chain: uint32
ospf: uint32
pce: uint32
te: uint32
rip: uint16
vrrp: uint16

Models that use timestamp:
key-chain:   yang:date-and-time
bfd: yang:date-and-time (in statistics)
interface: yang:date-and-time (in statistics)
isis: yang:timestamp
ietf-routing: yang:date-and-time
pce: yang:timestamp
rip: yang:date-and-time
vrrp: yang:date-and-time

I think that which one is appropriate depends on the situation. If the time
duration is a few seconds, it would be easy enough to show the number of
seconds. But if the time duration is hundreds of hours, it could be easier
to use time stamps. When we implement, time stamp is easy to do the
comparison, but we need to handle the situations when system time changes
and time zone (day light saving time) changes.

For our PIM model, based on the inputs from vendor implementation, it seems
that all vendors have implemented the time duration (though some may display
as hh:mm:ss instead of number of seconds). So we currently have such a
format in our model.

I think that we will bring up this topic during our discussion meetings,
maybe in some broader contexts like routing area Yang discussions.

As the draft updates, do you think that we should submit it as we have now?

Thanks,

- Xufeng

> -----Original Message-----
> From: Stig Venaas (svenaas) [mailto:[email-masked]]
> Sent: Friday, July 29, 2016 2:57 PM
> To: Xufeng Liu <[email-masked]>; [email-masked]
> Subject: Re: [Yang-multicast] draft-ietf-pim-yang-01.txt ready for WGLC?
> 
> Hi
> 
> On 7/29/2016 11:49 AM, Xufeng Liu wrote:
> > Hi Stig and all,
> >
> > I have updated the models to compile with the updated models that we
> > depend on, along with some syntax fixes and description cleanups. The
> > updated model files, tree views, and draft file are at
> > https://github.com/mcallisterjp/pim-yang.
> >
> > Please let me know for any comments. I'll submit it on Monday if no
> > objections.
> >
> > Also, I'm ok with going for last call.
> 
> Great, thanks. I actually have one question. For timers like expiry time,
is it
> common in models to just have a timer showing how many seconds (or
> whatever unit)? I think it would be easier and maybe more useful to have a
time
> stamp showing when it will expire.
> 
> I think time stamp is easier to implement. Say if your data is stored in
some kind
> of database queried by YANG, it is easier to just update a time stamp each
time
> you get a join, rather than frequently updating the expiry time. Also, for
the
> client/person consuming the data, there will be some delay from when you
got
> the data via the query until you see the value, so the expiry time may be
larger
> than the actual time, or you cannot say exactly when it will expire. One
can of
> course store a time stamp in a database and convert it to "time remaining"
when
> it is read though.
> 
> Thoughts?
> 
> Stig
> 
> > Thanks,
> >
> > - Xufeng
> >
> >> -----Original Message-----
> >> From: Yang-multicast [mailto:[email-masked]] On
> >> Behalf Of Stig Venaas (svenaas)
> >> Sent: Tuesday, July 26, 2016 3:14 PM
> >> To: [email-masked]
> >> Subject: Re: [Yang-multicast] draft-ietf-pim-yang-01.txt ready for
WGLC?
> >>
> >> Hi
> >>
> >> On 7/26/2016 11:18 AM, Xufeng Liu wrote:
> >>> Hi Stig,
> >>>
> >>> We are aware of the compilation issue, which is caused by the
> >>> updates from the models that we depend on. Will have the issue fixed
> >>> within next few days.
> >>
> >> Apart from that, if you're meeting tomorrow, could you discuss
> >> whether you
> > are
> >> OK with it going to last call? I suspect we won't get much input from
> > others until
> >> we do that.
> >>
> >> Stig
> >>
> >>> Thanks,
> >>>
> >>> - Xufeng
> >>>
> >>>> -----Original Message-----
> >>>> From: Yang-multicast [mailto:[email-masked]] On
> >>>> Behalf Of Stig Venaas
> >>>> Sent: Tuesday, July 26, 2016 12:47 PM
> >>>> To: [email-masked]
> >>>> Subject: [Yang-multicast] draft-ietf-pim-yang-01.txt ready for WGLC?
> >>>>
> >>>> Hi
> >>>>
> >>>> I've been told that we should publish our YANG models as quickly as
> >>> possible.
> >>>> The IETF in general is trying to get the models out ASAP. We
> >>>> basically
> >>> need to
> >>>> get them out there before people start using other models.
> >>>>
> >>>> Do you believe the draft is ready for WGLC? I guess there may be
> >>>> more work needed, but that way we can hopefully get people to
> >>>> carefully review the
> >>> draft.
> >>>>
> >>>> I saw an email saying that 01 doesn't compile though. If that is
> >>>> the only
> >>> known
> >>>> issue, could you post an 02 fixing this ASAP?
> >>>>
> >>>> Stig
> >>>>
> >>>> _______________________________________________
> >>>> Yang-multicast mailing list
> >>>> [email-masked]
> >>>> https://www.ietf.org/mailman/listinfo/yang-multicast
> >>>
> >>> _______________________________________________
> >>> Yang-multicast mailing list
> >>> [email-masked]
> >>> https://www.ietf.org/mailman/listinfo/yang-multicast
> >>>
> >>
> >> _______________________________________________
> >> Yang-multicast mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/yang-multicast
> >

---

From: "Stig Venaas (svenaas)" <[email-masked]>
Date: Mon, 1 Aug 2016 13:45:09 -0700

Hi

> maybe in some broader contexts like routing area Yang discussions.

Thanks for looking into this!

> As the draft updates, do you think that we should submit it as we have now?

Yes, I think it's good to submit what you have now, and we can start
WGLC. Hopefully we will get more people to review and some discussions
then.

Stig

---

From: "Xufeng Liu" <[email-masked]>
Date: Tue, 2 Aug 2016 11:56:43 -0400

Hi Stig,

Submitted updated draft-ietf-pim-yang-02.

Thanks,

- Xufeng

> Sent: Monday, August 1, 2016 4:45 PM
> > I have checked some other model drafts. Both durations and time stamps
> > are used. In general, time duration is used more than time stamps, as
> following:
> >
> > Models that use during:
> > evpn: uint32
> > bfd: uint32
> > I think that which one is appropriate depends on the situation. If the
> > time duration is a few seconds, it would be easy enough to show the
> > number of seconds. But if the time duration is hundreds of hours, it
> > could be easier to use time stamps. When we implement, time stamp is
> > easy to do the comparison, but we need to handle the situations when
> > system time changes and time zone (day light saving time) changes.
> >
> > For our PIM model, based on the inputs from vendor implementation, it
> > seems that all vendors have implemented the time duration (though some
> > may display as hh:mm:ss instead of number of seconds). So we currently
> > have such a format in our model.
> >
> > I think that we will bring up this topic during our discussion
> > meetings, maybe in some broader contexts like routing area Yang
discussions.
> Yes, I think it's good to submit what you have now, and we can start WGLC.
> Hopefully we will get more people to review and some discussions then.
> 
> Stig
> 
> > Thanks,
> >
> > - Xufeng
> >
WGLC?
> >>> depend on, along with some syntax fixes and description cleanups.
> >>> The updated model files, tree views, and draft file are at
> >>>>> updates from the models that we depend on. Will have the issue
> >>>>> fixed within next few days.
> >>>>

---

From: Pete McAllister <[email-masked]>
Date: Tue, 2 Aug 2016 16:02:26 +0000

Xufeng,

Thanks for resubmitting. I agree that probably WGLC is not premature, though there are certainly bits missing.

-----Original Message-----
From: Xufeng Liu <[email-masked]<mailto:[email-masked]%3e>>
To: 'Stig Venaas (svenaas)' <[email-masked]<mailto:[email-masked]%3e>>, [email-masked]<mailto:[email-masked]>
Subject: Re: [Yang-multicast] draft-ietf-pim-yang-01.txt ready for WGLC?
Date: Tue, 2 Aug 2016 11:56:43 -0400

Hi Stig,

Thanks,

- Xufeng

-----Original Message-----
From: Stig Venaas (svenaas) [mailto:[email-masked]]
Sent: Monday, August 1, 2016 4:45 PM
To: Xufeng Liu <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Yang-multicast] draft-ietf-pim-yang-01.txt ready for WGLC?

Hi

Hi Stig,

following:

Models that use during:
evpn: uint32
bfd: uint32

discussions.

As the draft updates, do you think that we should submit it as we have

now?

Stig

Thanks,

- Xufeng

-----Original Message-----
From: Stig Venaas (svenaas) [mailto:[email-masked]]
Sent: Friday, July 29, 2016 2:57 PM
To: Xufeng Liu <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Yang-multicast] draft-ietf-pim-yang-01.txt ready for

WGLC?

Hi

Hi Stig and all,

Great, thanks. I actually have one question. For timers like expiry
time,

is it

common in models to just have a timer showing how many seconds (or
whatever unit)? I think it would be easier and maybe more useful to
have a

time

I think time stamp is easier to implement. Say if your data is stored
in

some kind

of database queried by YANG, it is easier to just update a time stamp
each

time

you get a join, rather than frequently updating the expiry time.
Also, for

the

client/person consuming the data, there will be some delay from when
you

got

the data via the query until you see the value, so the expiry time
may be

larger

than the actual time, or you cannot say exactly when it will expire.
One

can of

course store a time stamp in a database and convert it to "time

remaining"

when

it is read though.

Thoughts?

Stig

Thanks,

- Xufeng

-----Original Message-----
To: [email-masked]<mailto:[email-masked]>

WGLC?

Hi

Hi Stig,

are

OK with it going to last call? I suspect we won't get much input
from

others until

we do that.

Stig

Thanks,

- Xufeng

-----Original Message-----
From: Yang-multicast [mailto:[email-masked]] On
Behalf Of Stig Venaas
Sent: Tuesday, July 26, 2016 12:47 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Yang-multicast] draft-ietf-pim-yang-01.txt ready for

WGLC?

Hi

I've been told that we should publish our YANG models as quickly
as

possible.

need to

draft.

known

Stig

_______________________________________________
Yang-multicast mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/yang-multicast

_______________________________________________
Yang-multicast mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/yang-multicast

_______________________________________________
Yang-multicast mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/yang-multicast

_______________________________________________
Yang-multicast mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/yang-multicast

---

From: "Stig Venaas (svenaas)" <[email-masked]>
Date: Tue, 2 Aug 2016 09:36:08 -0700

Hi

> though there are certainly bits missing.

Do you know specific things that are missing, or just a general
impression that there will be things missing?

I would be interested to know what you think might be missing or
what additional work is needed for the document.

Stig

> *From*: Xufeng Liu <[email-masked]
> <mailto:[email-masked]%3e>>
> *To*: 'Stig Venaas (svenaas)' <[email-masked]
> <mailto:[email-masked]%3e>>,
> [email-masked] <mailto:[email-masked]>
> *Subject*: Re: [Yang-multicast] draft-ietf-pim-yang-01.txt ready for WGLC?
> *Date*: Tue, 2 Aug 2016 11:56:43 -0400
>
> Hi Stig,
>
>> -----Original Message----- From: Stig Venaas (svenaas)
>> [mailto:[email-masked]] Sent: Monday, August 1, 2016 4:45 PM To:
>> Xufeng Liu <[email-masked]
>> <mailto:[email-masked]>>; [email-masked]
>> <mailto:[email-masked]> Subject: Re: [Yang-multicast]
>> draft-ietf-pim-yang-01.txt ready for WGLC? Hi On 8/1/2016 1:25 PM,
>> Xufeng Liu wrote:
>>> Hi Stig, I think that it is an interesting topic to be discussed. I
>>> have checked some other model drafts. Both durations and time stamps
>>> Models that use during: evpn: uint32 bfd: uint32 bgp: uint16,
>>> decimal64, yang:timeticks ietf-routing: uint16, uint32 isis: uint16
>>> l2vpn: uint32, uint16 ldp: uint16 key-chain: uint32 ospf: uint32 pce:
>>> uint32 te: uint32 rip: uint16 vrrp: uint16 Models that use timestamp:
>>> key-chain: yang:date-and-time bfd: yang:date-and-time (in statistics)
>>> interface: yang:date-and-time (in statistics) isis: yang:timestamp
>>> ietf-routing: yang:date-and-time pce: yang:timestamp rip:
>>> yang:date-and-time vrrp: yang:date-and-time I think that which one is
>>> appropriate depends on the situation. If the time duration is a few
>>> seconds, it would be easy enough to show the number of seconds. But
>>> if the time duration is hundreds of hours, it could be easier to use
>>> time stamps. When we implement, time stamp is easy to do the
>>> comparison, but we need to handle the situations when system time
>>> changes and time zone (day light saving time) changes. For our PIM
>>> model, based on the inputs from vendor implementation, it seems that
>>> all vendors have implemented the time duration (though some may
>>> display as hh:mm:ss instead of number of seconds). So we currently
>>> have such a format in our model. I think that we will bring up this
>>> topic during our discussion meetings, maybe in some broader contexts
>>> like routing area Yang
>
> discussions.
>> then. Stig
>>> Thanks, - Xufeng
>>>> -----Original Message----- From: Stig Venaas (svenaas)
>>>> [mailto:[email-masked]] Sent: Friday, July 29, 2016 2:57 PM To:
>>>> Xufeng Liu <[email-masked]
>>>> <mailto:[email-masked]>>; [email-masked]
>>>> <mailto:[email-masked]> Subject: Re: [Yang-multicast]
>>>> draft-ietf-pim-yang-01.txt ready for
>
> WGLC?
>>>> Hi On 7/29/2016 11:49 AM, Xufeng Liu wrote:
>>>>> Hi Stig and all, I have updated the models to compile with the
>>>>> updated models that we depend on, along with some syntax fixes and
>>>>> description cleanups. The updated model files, tree views, and
>>>>> draft file are at https://github.com/mcallisterjp/pim-yang. Please
>>>>> let me know for any comments. I'll submit it on Monday if no
>>>>> objections. Also, I'm ok with going for last call.
>>>> stamp showing when it will expire. I think time stamp is easier to
>>>> implement. Say if your data is stored in
>>> some kind
>>>> it is read though. Thoughts? Stig
>>>>> Thanks, - Xufeng
>>>>>> -----Original Message----- From: Yang-multicast
>>>>>> [mailto:[email-masked]] On Behalf Of Stig Venaas
>>>>>> (svenaas) Sent: Tuesday, July 26, 2016 3:14 PM To:
>>>>>> [email-masked] <mailto:[email-masked]> Subject:
>>>>>> Re: [Yang-multicast] draft-ietf-pim-yang-01.txt ready for
>>> WGLC?
>>>>>> Hi On 7/26/2016 11:18 AM, Xufeng Liu wrote:
>>>>>>> Hi Stig, We are aware of the compilation issue, which is caused
>>>>>>> by the updates from the models that we depend on. Will have the
>>>>>>> issue fixed within next few days.
>>>>>> we do that. Stig
>>>>>>> Thanks, - Xufeng
>>>>>>>> -----Original Message----- From: Yang-multicast
>>>>>>>> [mailto:[email-masked]] On Behalf Of Stig
>>>>>>>> Venaas Sent: Tuesday, July 26, 2016 12:47 PM To:
>>>>>>>> [email-masked] <mailto:[email-masked]>
>>>>>>>> Hi I've been told that we should publish our YANG models as
>>>>>>>> quickly as
>>>>>>> possible.
>>>>>>>> get them out there before people start using other models. Do
>>>>>>>> you believe the draft is ready for WGLC? I guess there may be
>>>>>>>> issue, could you post an 02 fixing this ASAP? Stig
>>>>>>>> _______________________________________________ Yang-multicast
>>>>>>>> mailing list [email-masked]
>>>>>>>> <mailto:[email-masked]>
>>>>>>> _______________________________________________ Yang-multicast
>>>>>>> mailing list [email-masked]
>>>>>>> <mailto:[email-masked]>
>>>>>> _______________________________________________ Yang-multicast
>>>>>> mailing list [email-masked]
>>>>>> <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>