Subject: [Yang-multicast] Proceeding with YANG multicast drafts

From: "Stig Venaas (svenaas)" <[email-masked]>
Date: Thu, 2 Feb 2017 13:27:26 -0800

Hi

We need to see how to proceed with these drafts.

draft-ietf-pim-yang-03
This was waiting for resolution of the BFD issue. It looks like we
know how to proceed now. Are you updating the draft with the changes
needed? Anything else other than BFD? We can hopefully do a final
WGLC when we have the next revision.

draft-ietf-pim-igmp-mld-yang-01
Is this ready for WGLC you think? Are you planning any changes?

draft-zhang-pim-msdp-yang-02
Can I start an adoption call for this, or do you want to make any
changes first?

Stig

---

From: "Xufeng Liu" <[email-masked]>
Date: Fri, 3 Feb 2017 12:19:49 -0500

Hi Stig,

> -----Original Message-----
> From: Yang-multicast [mailto:[email-masked]] On Behalf Of
> Stig Venaas (svenaas)
> Sent: Thursday, February 2, 2017 4:27 PM
> To: [email-masked]
> Cc: 'Mike McBride' <[email-masked]>
> Subject: [Yang-multicast] Proceeding with YANG multicast drafts
> 
> Hi
> 
> This was waiting for resolution of the BFD issue. It looks like we know
how to
> proceed now. Are you updating the draft with the changes needed? Anything
> else other than BFD? We can hopefully do a final WGLC when we have the
next
> revision.

[Xufeng] Yes. We are updating the draft to incorporate BFD according to the
resolution. We are also updating the draft according to the comments from
Yang doctor's review. Other than these, currently there is a draft defining
common Yang types in Routing Area
(https://tools.ietf.org/html/draft-ietf-rtgwg-routing-types-00). I'm not
sure if we need to synch with it or we can proceed independently.

> Is this ready for WGLC you think? Are you planning any changes?

[Xufeng] During the process of updating draft-ietf-pim-yang-03, I have found
some items that are obliviously applicable to this draft also. I'm thinking
to do a quick update within a week or two. 

> Can I start an adoption call for this, or do you want to make any changes
first?

[Xufeng] I think that the adoption call can start now. 

> 
> Stig
> 
> _______________________________________________
> Yang-multicast mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-multicast

---

From: "Stig Venaas (svenaas)" <[email-masked]>
Date: Fri, 3 Feb 2017 09:23:23 -0800

Hi

> sure if we need to synch with it or we can proceed independently.

Are there types defined in this 00 version that you are not using, and
maybe should use? Or are you more concerned that there might be later
changes? It would be good to be in line with this version where you
think it makes sense. I wouldn't want us to wait on future changes. If
necessary that can be done later in the process too.

> to do a quick update within a week or two.

OK, thanks.

> [Xufeng] I think that the adoption call can start now.

Great,

Stig

---

From: "Xufeng Liu" <[email-masked]>
Date: Fri, 3 Feb 2017 12:29:18 -0500

> From: Stig Venaas (svenaas) [mailto:[email-masked]]
> Sent: Friday, February 3, 2017 12:23 PM
> To: Xufeng Liu <[email-masked]>; [email-masked]
> Subject: Re: [Yang-multicast] Proceeding with YANG multicast drafts
> 
> Hi
> 
> >> From: Yang-multicast [mailto:[email-masked]] On
> >> Behalf Of Stig Venaas (svenaas)
> >> know
> >> proceed now. Are you updating the draft with the changes needed?
> >> Anything else other than BFD? We can hopefully do a final WGLC when
> >> we have the
> > next
> >> revision.
> >
> > [Xufeng] Yes. We are updating the draft to incorporate BFD according
> > to the resolution. We are also updating the draft according to the
> > comments from Yang doctor's review. Other than these, currently there
> > is a draft defining common Yang types in Routing Area
> > (https://tools.ietf.org/html/draft-ietf-rtgwg-routing-types-00). I'm
> > not sure if we need to synch with it or we can proceed independently.
> 
maybe
> should use? Or are you more concerned that there might be later changes?
[Xufeng] Right. We haven't used it because there might be later changes.
 It
> would be good to be in line with this version where you think it makes
sense. I
> wouldn't want us to wait on future changes. If necessary that can be done
later
> in the process too.
[Xufeng] Alright. I'll use it during the updating.

> > [Xufeng] During the process of updating draft-ietf-pim-yang-03, I have
> > found some items that are obliviously applicable to this draft also.
> > I'm thinking to do a quick update within a week or two.
> >
> 
> OK, thanks.
> 
> >> changes

---

From: "Stig Venaas (svenaas)" <[email-masked]>
Date: Fri, 3 Feb 2017 09:53:45 -0800

Hi

> [Xufeng] Alright. I'll use it during the updating.

It's really up to you guys what makes sense. One thing to consider I
guess is whether other routing drafts are also adopting them. I don't
know, so I'll leave it to you.

---

From: Benoit Claise <[email-masked]>
Date: Tue, 7 Feb 2017 12:29:19 +0100

On 2/3/2017 6:53 PM, Stig Venaas (svenaas) wrote:
> guess is whether other routing drafts are also adopting them. 
Yes, there are.

Regards, B.
> I don't
> .

---

From: "Stig Venaas (svenaas)" <[email-masked]>
Date: Wed, 8 Feb 2017 13:35:02 -0800

Hi

I'm hoping that both the pim and igmp/mld drafts can be updated within
a week or two. I'll start WGLCs as soon as you have submitted the new
versions.

I started the adoption call for the msdp draft.

Stig

---

From: "Xufeng Liu" <[email-masked]>
Date: Fri, 10 Feb 2017 10:11:30 -0500

Hi,

I have just updated the model with the aligned bfd and ietf-routing-types,
along with some text changes to address Yang doctor's review comments. The
updated model and draft have been put to GitHub:
https://github.com/mcallisterjp/pim-yang
I cannot publish this version yet, because it uses some un-published
upcoming types from ietf-routing-types (which should be updated within a
couple of weeks).

Meanwhile, can authors and contributors review this version on GitHub, and
help to fix any potential issues?

Thanks,

- Xufeng

> Sent: Wednesday, February 8, 2017 4:35 PM
> I'm hoping that both the pim and igmp/mld drafts can be updated within a
week
> or two. I'll start WGLCs as soon as you have submitted the new versions.
>

---

From: Benoit Claise <[email-masked]>
Date: Fri, 10 Feb 2017 17:19:26 +0100

Hi Xufeng,
> upcoming types from ietf-routing-types (which should be updated within a
Instead of waiting on the dependencies, I propose that you publish now 
with the new types.
While waiting for publication (of the ietf-routing-types), it doesn't 
hurt to have the same typedefs in both dratfs.
We just have to remember to use the import once ietf-routing-types is 
finalized.

Regards, B.

---

From: "Stig Venaas (svenaas)" <[email-masked]>
Date: Fri, 10 Feb 2017 08:23:15 -0800

Hi

> We just have to remember to use the import once ietf-routing-types is

If you post it now I can start the WGLC. We can still make some minor
adjustments in a couple of weeks when the routing types draft has been
updated and we're done with the WGLC.

Stig

---

From: "Xufeng Liu" <[email-masked]>
Date: Thu, 16 Feb 2017 10:13:07 -0500

Hi Stig,

Will post the updated within a couple of days.

Thanks,

- Xufeng

> Sent: Friday, February 10, 2017 11:23 AM
> To: Benoit Claise <[email-masked]>; Xufeng Liu
<[email-masked]>;
> [email-masked]
> >> I have just updated the model with the aligned bfd and
> >> ietf-routing-types, along with some text changes to address Yang
> >> doctor's review comments.
> >> The
> >> upcoming types from ietf-routing-types (which should be updated
> >> within a couple of weeks).
updated
> and we're done with the WGLC.
> 
> Stig
> 
> > Regards, B.
> >>
> >> Meanwhile, can authors and contributors review this version on
> >> GitHub, and help to fix any potential issues?
> >>
> >> Thanks,
> >>
> >> - Xufeng
> >>

---

From: "Xufeng Liu" <[email-masked]>
Date: Mon, 20 Feb 2017 09:58:52 -0500

HI Stig,

We have just posted the new version. 

The dependency (ietf-routing-types) was also updated, so we have got what we
need from that draft.

Thanks,

- Xufeng

> From: Xufeng Liu [mailto:[email-masked]]
> Sent: Thursday, February 16, 2017 10:13 AM
> To: 'Stig Venaas (svenaas)' <[email-masked]>; 'Benoit Claise'
> <[email-masked]>; [email-masked]
> Subject: RE: [Yang-multicast] Proceeding with YANG multicast drafts
> 
> Hi Stig,
> 
> > >> I cannot publish this version yet, because it uses some
> > >> un-published upcoming types from ietf-routing-types (which should
> > >> be updated within a couple of weeks).
> > > Instead of waiting on the dependencies, I propose that you publish
> > > now with the new types.
> > > While waiting for publication (of the ietf-routing-types), it
> > > doesn't hurt to have the same typedefs in both dratfs.
> > > We just have to remember to use the import once ietf-routing-types
> > > is finalized.
> >

---

From: "Stig Venaas (svenaas)" <[email-masked]>
Date: Mon, 20 Feb 2017 09:59:26 -0800

Hi

> The dependency (ietf-routing-types) was also updated, so we have got what we

Great, I'll start WGLC then.

Stig

---

From: "Stig Venaas (svenaas)" <[email-masked]>
Date: Mon, 20 Feb 2017 10:36:05 -0800

Hi

I've started the WGLC, it ends March 2nd. I hope all the authors as
well as everyone else on this mailing list can carefully review this
last version. Of course also people in the working group in general.

Did you verify that this last version compiles?

Also, in order to request publishing the draft, I will need each of
the authors to state whether they are aware of any IPR for this draft.

Stig

---

From: "Xufeng Liu" <[email-masked]>
Date: Mon, 20 Feb 2017 13:39:13 -0500

Hi Stig,

Thanks.

I have verified that the latest version compiles fine.

Regards,

- Xufeng

> Sent: Monday, February 20, 2017 1:36 PM
> To: Xufeng Liu <[email-masked]>; 'Benoit Claise'
> I've started the WGLC, it ends March 2nd. I hope all the authors as well
as
> everyone else on this mailing list can carefully review this last version.
Of course
> also people in the working group in general.
> 
> Also, in order to request publishing the draft, I will need each of the
authors to
> state whether they are aware of any IPR for this draft.
> 
> Stig