Subject: Re: [Yot] comi.space maintenance

From: Michel Veillette <[email-masked]>
Date: Thu, 13 Sep 2018 16:20:53 +0000

Hi Alexander, Hi Peter, Hi Carsten

I'm currently updating "draft-ietf-core-comi".

What should I do about the name?
Should I change CoMI to CORECONF in the entire document?
Or should I keep the draft the way it is?

What was the resolution on this subject at the last IETF?

Regards,
Michel

From: Alexander Pelov <[email-masked]>
Sent: Thursday, September 13, 2018 11:20 AM
To: [email-masked]
Cc: Michel Veillette <[email-masked]>; Michael Richardson <[email-masked]>; Panos Kampanakis (pkampana) <[email-masked]>
Subject: Re: comi.space maintenance

Hi Peter,

Thanks for reaching out!
Yes, I think you are right that we should have a plan for the maintenance of comi.space

Let's discuss this before the next IETF?
(currently I'm in the US for a couple of days, maybe beginning of October?)

Alexander

On Wed, 12 Sep 2018, 08:30 Peter van der Stok <[email-masked]<mailto:[email-masked]>> wrote:
Hi Alexander,

We use com.space to allocate SID values to the fields of the voucher specified in our yang files .
See anima-constrained-voucher for details.

Currently, we experience a problem with the version of the pyang tools prepared by Michel.
Michel has been kind enough to provide use with all necessary information and the supporting files.
Michael Richardson tries to debug the python code and may come up with a a solution.

That will remove our problems for the time being, but we risk that other people may use a different version of the pyang tools because Michel seems to have a limited time to occupy himself with the maintenance of the pyang tool.

Do you have suggestions, or are already procedures in place, to assure the continued maintenance of comi.space also after Michel may become unavailable (other job, health problems, and what not).

May be I worry over a non existing problem.
If not, it would be nice if we could discuss this on the Core ML, where all the work originated.

Greetings, thanks for your answer,

Peter
--
Peter van der Stok
vanderstok consultancy
mailto: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
www: www.vanderstok.org<http://www.vanderstok.org>
tel NL: +31(0)492474673     F: +33(0)966015248

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 13 Sep 2018 18:41:01 +0200

> On Sep 13, 2018, at 18:20, Michel Veillette <[email-masked]> wrote:
> 

The resolution was that we want to call the whole thing Coreconf, just as the XML message thing is called Netconf and the HTTP-based thing is called RESTCONF.

We did want to keep the name COMI around (to honor Peter’s substantial contributions, but also for people who have found that name somewhere and want to google things).  The idea was to continue to call the binding of Coreconf to CoAP COMI, i.e., what is in draft-ietf-core-comi right now.  So YANG-CBOR + COMI + SID management + (maybe a few specific modules) = Coreconf.   But that was a bit less firm, so if there is a reason to revisit this, we should.

Grüße, Carsten

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 13 Sep 2018 18:50:23 +0200

> The resolution was that we want to call the whole thing Coreconf, just as the XML message thing is called Netconf and the HTTP-based thing is called RESTCONF.

We do write NETCONF (and not Netconf or NetConf). So we have NETCONF
and RESTCONF and perhaps also CORECONF, unless people insist on a
different capitalization style.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 13 Sep 2018 19:03:54 +0200

> different capitalization style.

Thanks for putting this right — I was unsure about the right capitalization, and of course we want to follow the lead of NETCONF and RESTCONF here.  (I do get some FORTRAN vibes from this, but that’s probably just my age :-)

Grüße, Carsten